<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"rHJ9vP1Xz0ktKr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"waff"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "waff/web/news/top-story",
    "authors": [
                  
                    {
                      "_id": "egraves",
                      "name": "Eric Graves",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2020/12/12/huntsville-police-investigating-hit-and-run-university-dr/",
    "contentId": "R4Z5KGXAIZHGJHP7VGYOY7ZYQQ",
    "contentName": "Huntsville Police identify man involved in hit-and-run on University Dr.",
    "contentOwner": "waff",
    "contentTags":  [
                  
                    {
                      "text": "huntsville",
                      "description": "huntsville",
                      "slug": "huntsville"
                    },
                  
                    {
                      "text": "police",
                      "description": "police",
                      "slug": "police"
                    },
                  
                    {
                      "text": "hit and run",
                      "description": "hit and run",
                      "slug": "hit-and-run"
                    },
                  
                    {
                      "text": "university",
                      "description": "university",
                      "slug": "university"
                    },
                  
                    {
                      "text": "hpd",
                      "description": "hpd",
                      "slug": "hpd"
                    },
                  
                ],
    "contentType": "story",
    "datePublished": "2020-12-12T12:47:25.902Z",
    "description": "One HPD officer on scene said the hit and run happened around 3:30 a.m. at the intersection of University Dr. and Enterprise Way.",
    "distributorCategory": "staff",
    "distributorMode": "reference_denormalized",
    "distributorName": "Gray TV Stations",
    "distributorReferenceId": "dee592ee-659e-4038-a289-0bfe818887ca",
    "distributorSubCategory": "gray-original-content",
    "hasVideo": true,
    "metaDescription": "One HPD officer on scene said the hit and run happened around 3:30 a.m. at the intersection of University Dr. and Enterprise Way.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "Top Story",
                            "_id": "/news/top-story",
                            "path": "/news/top-story",
                          }
                        
                      ,
    "publishedDay": "12",
    "publishedMonth": "12",
    "publishedYear": "2020",
    "stationName": "waff",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="mLQT0tJku5PNKIE_6N8rGEBc34TJrPJ1Nte8uNouZLo"/> <title>Huntsville Police identify man involved in hit-and-run on University Dr.</title> <meta name="keywords" content="huntsville, police, hit and run, university, hpd"> <meta name="news_keywords" content="huntsville, police, hit and run, university, hpd"/> <meta name="date" content="2020-12-12T12:47:25.902Z"/> <meta itemprop="description" name="description" content="One HPD officer on scene said the hit and run happened around 3:30 a.m. at the intersection of University Dr. and Enterprise Way."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="https://www.waff.com/2020/12/12/huntsville-police-investigating-hit-and-run-university-dr/"> <meta name="twitter:title" content="Huntsville Police identify man involved in hit-and-run on University Dr."/> <meta name="twitter:image" content="https://www.waff.com/resizer/r7GufLTa-BFHWRA9uOUyu3aUZRY=/1200x0/cloudfront-us-east-1.images.arcpublishing.com/raycom/A7OIEOIZ7FDOROZRT22VX7ZORE.png"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="One HPD officer on scene said the hit and run happened around 3:30 a.m. at the intersection of University Dr. and Enterprise Way."/> <meta name="twitter:site" content="@waff48"/> <meta name="twitter:creator" content="@waff48"> <meta property="og:url" content="https://www.waff.com/2020/12/12/huntsville-police-investigating-hit-and-run-university-dr/"/> <meta property="og:title" content="Huntsville Police identify man involved in hit-and-run on University Dr."/> <meta itemprop="image" property="og:image" content="https://www.waff.com/resizer/r7GufLTa-BFHWRA9uOUyu3aUZRY=/1200x0/cloudfront-us-east-1.images.arcpublishing.com/raycom/A7OIEOIZ7FDOROZRT22VX7ZORE.png"/> <meta property="og:description" content="One HPD officer on scene said the hit and run happened around 3:30 a.m. at the intersection of University Dr. and Enterprise Way."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="https://www.waff.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="184935004909933"/> <meta property="fb:pages" content="40307674652"/> <meta property="fb:admins" content="644426401"/> <meta name="burst" content="waff"/> <meta property="article:publisher" content="https://facebook.com/waff48"> <meta property="article:tag" content="huntsville, police, hit and run, university, hpd"> <link rel="amphtml" href="/2020/12/12/huntsville-police-investigating-hit-and-run-university-dr/?outputType=amp"> <meta name="author" content="Eric Graves"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Huntsville Police identify man involved in hit-and-run on University Dr.",
        
        "image": {
          "@type": "ImageObject",
          "url": "https://www.waff.com/resizer/r7GufLTa-BFHWRA9uOUyu3aUZRY=/1200x0/cloudfront-us-east-1.images.arcpublishing.com/raycom/A7OIEOIZ7FDOROZRT22VX7ZORE.png",
          "height": 1080.0,
          "width": 1200
        },
        
        "datePublished": "2020-12-12T19:41:32.634Z",
        "dateModified": "2020-12-12T12:47:25.902Z",
        "articleBody": "HUNTSVILLE, Ala. (WAFF) - Update: Huntsville Police Department identified the man who was involved in a hit-and-run on December 12. WAFF is told that Daniel Mark Banks was arrested for fleeing the scene of the accident. Banks was allegedly driving under the influence. HPD is investigating this case.Original: One person is at Huntsville Hospital with severe injuries after what Huntsville Police said was a hit-and-run early Saturday morning.One HPD officer on scene said the hit and run happened around 3:30 a.m. at the intersection of University Dr. and Enterprise Way.At last update, HPD is still looking for the suspect who hit the victim with their car. Officers blocked off westbound University Dr. between Enterprise Way and Perimeter Parkway NW while they investigated the scene.This is a developing story, we will update you when we know more.Copyright 2020 WAFF. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "Eric Graves"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "WAFF",
        "logo": {
          "@type": "ImageObject",
          "url": "https://www.waff.com/pb/resources/images/rm_icons/waff-icon.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "One HPD officer on scene said the hit and run happened around 3:30 a.m. at the intersection of University Dr. and Enterprise Way."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "WAFF",
        "url": "https://www.waff.com",
        "logo": "https://www.waff.com/pb/resources/images/rm_icons/waff-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://facebook.com/waff48" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-framework199071bbaf3b531cbc00.css?v=101" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/waff-logo.svg?v=101)}.logo.logo-footer{background-image:url(/pb/resources/images/footer_icons/waff-logo.svg?v=101)}</style> <link href="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-framework199071bbaf3b531cbc00.css?v=101" rel="stylesheet"/> <link href="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-features199071bbaf3b531cbc00.css?v=101" rel="stylesheet"/> <link href="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-services199071bbaf3b531cbc00.css?v=101" rel="stylesheet"/> <script>!function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2cyo6jdzTrLVCGuTBLwhTRy_3ThV5534y5z8by0csww1UnjuaWHkr8mw",o.parentNode.insertBefore(t,o)}(document,"script"),function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}}(window,"admiral");
!function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)}(window,"googletag","function");
!function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if(function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}}(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=
function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2omaaXRAtHBmSUUbWRCZDunlRfU0kCBwEyna1atCIrjNLuHKYqUtb6jQgRT_v4Jiiu244PgkHA",t.parentNode.insertBefore(o,t)}(document,window,"__uspapi","__uspapiLocator","script");</script> <script src="/pb/gr/c/default/rHJ9vP1Xz0ktKr/arcAdsJS/cdbd7d78da.js?v=101"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> <script>!function(n){if(!window.cnxps){window.cnxps={},window.cnxps.cmd=[];var t=n.createElement("iframe");t.display="none",t.onload=function(){var n=t.contentWindow.document,c=n.createElement("script");c.src="//cd.connatix.com/connatix.playspace.js",c.setAttribute("async","1"),c.setAttribute("type","text/javascript"),n.body.appendChild(c)},n.head.appendChild(t)}}(document);</script> 
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"true","rua.cpush":"true","rua.upre":"true","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-75e2d01a-f31c-4dbf-a79f-bfee79857452","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="9M6D5-WJNT4-MVH7K-W9TQ2-JG3AQ",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"9M6D5-WJNT4-MVH7K-W9TQ2-JG3AQ",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubax3f2jsx6vkf4a-f-e1486bf14-clientnsv4-s.akamaihd.net",i={"ak.v":"29","ak.cp":"737375","ak.ai":parseInt("478397",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"189690d8","ak.r":33470,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":45860,"ak.gh":"23.217.116.149","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1607815544","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==mmY+jjtCvD8BAQmJBIlgKPTm8O8uI2jdc6x+eixosfCHB2Bn2+qYFkc9qb9hL+1/erHrUIPqvEpTqhd7PVvhyMRZra2FNHxbAhTrrNSuKa1Dq/xD4iVkBJfPkckTCiY3Ui7jLtu6W0Ib7OVT9BfCxzHegfWDMq1IZM17MsK5ilC2MC3k8vTeKfTeCaWdfH6zQAJY8WtjNppLwxqTQsfHcd1CLfvNagIFiHxCzm1HCSabVIIj4lJs+wOvFMVpPv9Q62oZiLrByLQtWTIKccwcFMda+vhdCYh4bAUWs18zr1PypYCXcD12H44Ww7yBCJNXJZqP+kpeq0o5Tsft2j1U9oZF2UcnLLRh6YKIpIzKwFWTNn87YH4AhwVaHkORxmRH4DsrMd5sek++TTSOoM1R4VcegcWF30XFsjVstQeD0hA=","ak.pv":"19","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> 
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"true","rua.cpush":"true","rua.upre":"true","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-75e2d01a-f31c-4dbf-a79f-bfee79857452","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
  <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="9M6D5-WJNT4-MVH7K-W9TQ2-JG3AQ",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"9M6D5-WJNT4-MVH7K-W9TQ2-JG3AQ",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubax3f2jsx6vkf4a-f-e1486bf14-clientnsv4-s.akamaihd.net",i={"ak.v":"29","ak.cp":"737375","ak.ai":parseInt("478397",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"189690d8","ak.r":33470,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":45860,"ak.gh":"23.217.116.149","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1607815544","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==mmY+jjtCvD8BAQmJBIlgKPTm8O8uI2jdc6x+eixosfCHB2Bn2+qYFkc9qb9hL+1/erHrUIPqvEpTqhd7PVvhyMRZra2FNHxbAhTrrNSuKa1Dq/xD4iVkBJfPkckTCiY3Ui7jLtu6W0Ib7OVT9BfCxzHegfWDMq1IZM17MsK5ilC2MC3k8vTeKfTeCaWdfH6zQAJY8WtjNppLwxqTQsfHcd1CLfvNagIFiHxCzm1HCSabVIIj4lJs+wOvFMVpPv9Q62oZiLrByLQtWTIKccwcFMda+vhdCYh4bAUWs18zr1PypYCXcD12H44Ww7yBCJNXJZqP+kpeq0o5Tsft2j1U9oZF2UcnLLRh6YKIpIzKwFWTNn87YH4AhwVaHkORxmRH4DsrMd5sek++TTSOoM1R4VcegcWF30XFsjVstQeD0hA=","ak.pv":"19","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="faYVSr1Xz0ktKr"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.waff.com/business-spotlight" class="color-grey-dark">Business Spotlight</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://waff.incentrev.com/huntsville/deals" class="color-grey-dark">Deals</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.waff.com/2020/10/01/waff-s-pet-week-tune-every-october-friday-noon/" class="color-grey-dark">Paws for the Cause</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.waff.com/2020/11/04/can-a-thon-how-you-can-participate-nov-through-dec/" class="color-grey-dark">Can-a-thon 2020</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.waff.com/2020/12/02/vote-your-favorite-cookie-chance-win-publix-gift-card/#/bracket?round=3" class="color-grey-dark">Vote for Your Favorite Cookie Contest</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.waff.com/2020/12/07/waffs-days-giveaways-contest/#//" class="color-grey-dark">12 Days of Giveaways</a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f0aKfloXz0ktKr"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0ExsO8Xz0ktKr"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.waff.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row relative spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/homepage" class="">Home</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/health/coronavirus" class="">Coronavirus</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/48now" class="">48 Now</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/programming" class="">TV</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.tennesseevalleyweekend.com/" class="">TN VALLEY LIVING</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/about-us" class="">About Us</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div class="app-bar-tray" data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <div class="flex-grid"> <div class="tray-section tray-section-1 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/homepage" class="color-white">Home</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/classroom" class="color-white">Coronavirus and the Classroom</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/news/coronavirus" class="color-white">Coronavirus Updates</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.waff.com/roku-amazon-fire-tv/" class="color-white">Roku, Amazon FireTV and more</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.waff.com/programming/waff-48-morning-show/" class="color-white">Your First Alert in the Morning</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="https://www.waff.com/community/user-content" class="color-white">WAFF Pix</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/politics/election-results" class="color-white">Election Results</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="https://www.waff.com/community/calendar/" class="color-white">Community Calendar</a> </div> </div> </div> </div> <div class="tray-section tray-section-2 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="https://www.waff.com/live" class="color-white">Live Newscasts & Replays</a> </h3> </div> </div> <div class="tray-section tray-section-3 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/news" class="color-white">News</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/news/huntsville-madison" class="color-white">Huntsville - Madison</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/news/limestone-morgan" class="color-white">Limestone - Morgan</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/news/sandmountain" class="color-white">Sand Mountain</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/news/shoals" class="color-white">Shoals</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/news/investigate" class="color-white">48 Investigates</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/crime-stoppers/" class="color-white">Crime Stoppers</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="https://www.fullcourtgreta.com/" class="color-white">Full Court Press with Greta Van Susteren</a> </div> </div> </div> </div> <div class="tray-section tray-section-4 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/community" class="color-white">Community</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/community/user-content" class="color-white">Send Your Photos</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.waff.com/haleys-for-your-home/" class="color-white">Be Inspired</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.waff.com/2020/12/02/vote-your-favorite-cookie-chance-win-publix-gift-card/#/bracket?round=3" class="color-white">Vote for Your Favorite Cookie Contest</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.waff.com/2020/12/07/waffs-days-giveaways-contest/#//" class="color-white">12 Days of Giveaways</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="https://www.waff.com/2020/10/01/waff-s-pet-week-tune-every-october-friday-noon/" class="color-white">Paws for the Cause</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.waff.com/2020/11/04/can-a-thon-how-you-can-participate-nov-through-dec/" class="color-white">Can-a-thon 2020</a> </div> </div> </div> </div> <div class="tray-section tray-section-5 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/weather" class="color-white">Weather</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.waff.com/weather#radar" class="color-white">You Track Storms</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/weather/cams" class="color-white">Alfa Camera Network</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.waff.com/weather/radar" class="color-white">First Alert Doppler Radar</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.waff.com/story/36630193/waff-48-first-alert-weather-now-featured-on-amazon-alexa" class="color-white">First Alert Weather on Amazon Alexa</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="https://www.waff.com/2019/03/22/waff-first-alert-storm-tracker/" class="color-white">48 First Alert Storm Tracker</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.waff.com/story/37694904/what-is-a-first-alert-weather-day" class="color-white">What is a First Alert Weather Day?</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="https://www.waff.com/story/5218974/how-to-program-your-midland-all-hazards-weather-radio" class="color-white">How to Program your Midland Weather Radio</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="https://www.waff.com/news-and-weather-app/" class="color-white">First Alert Weather App</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-11"> <a href="https://www.waff.com/story/10844843/first-alert-storm-trackers-on-the-radio" class="color-white">First Alert Weather on the Radio</a> </div> </div> </div> </div> <div class="tray-section tray-section-6 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/sports" class="color-white">Sports</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/sports/ncaa" class="color-white">NCAA</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/sports/high-school" class="color-white">High-school</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/sports/local" class="color-white">Local</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.waff.com/2020/09/17/huntsville-madison-teams-up-with-sprocket-keep-children-safe-during-an-emergency/" class="color-white">Safety with Sprocket</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/sports/high-school/football" class="color-white">48 Blitz</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.waff.com/sports/scoreboard/" class="color-white">High School Football Scores</a> </div> </div> </div> </div> <div class="tray-section tray-section-7 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/programming" class="color-white">TV</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.waff.com/programming/schedule/" class="color-white">Program Schedule</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.circleallaccess.com" class="color-white">Circle - Country Music & Lifestyle</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.waff.com/programming/48-2-bounce-tv/" class="color-white">Bounce TV</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.graydc.com/" class="color-white">Gray DC Bureau</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="https://www.grittv.com/tv-schedule/" class="color-white">Grit TV</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.investigatetv.com/" class="color-white">Investigate TV</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="https://www.waff.com/story/30654342/where-to-find-482-and-483-on-cable" class="color-white">Where to find 48.2 and 48.3 on cable</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="https://www.waff.com/story/23392326/absolutely-alabama" class="color-white">Absolutely Alabama with Fred Hunter</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-11"> <a href="https://www.waff.com/2020/11/18/enter-what-is-your-pet-thankful-contest/" class="color-white">What is Your Pet Thankful For?</a> </div> </div> </div> </div> <div class="tray-section tray-section-8 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/about-us" class="color-white">About Us</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.waff.com/about-us/meet-the-team/" class="color-white">Meet The Team</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://gray.tv/careers#currentopenings" class="color-white">Job Openings</a> </div> </div> </div> </div> </div> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0MEpCZXz0ktKr"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-waff-breaking/" data-url="/pb/api/v2/render/feature" data-website="waff" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fZgFpz1Xz0ktKr"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/waff-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="waff"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fOcnHR1Xz0ktKr"> <div id="ad1189-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1189" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1189",slotName:"waff/web/news/top-story",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"R4Z5KGXAIZHGJHP7VGYOY7ZYQQ"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},
{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="f0G8x4vXz0ktKr"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> <li class=""> <a class="tag unstyled-link call-to-action uppercase bold unstyled-link tag-first" href="https://www.waff.com/news/top-story"> Top Story </a> </li> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Huntsville Police identify man involved in hit-and-run on University Dr.</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-article-goldfish-video" id=""> <div class="video"> <div class="goldfish-video" data-video-id="powa-381-cfeca84f-690d-4ae3-b58a-d45d66311504" data-script-path="d3mo2m0b34ee8e" data-environment="prod"></div> <div class="goldfish-player" data-page-on="1" data-producer=""> <div class="powa" id="powa-381-cfeca84f-690d-4ae3-b58a-d45d66311504" data-ping-rate="15" data-org="raycom" data-uuid="cfeca84f-690d-4ae3-b58a-d45d66311504" data-playthrough="true" data-sticky="true" data-autoplay="true" data-preroll-ad-path="63316753/waff/web/news/livestream" data-ads="true"></div> </div> <figcaption class="caption-text spaced spaced-top spaced-xs flex-container-row justify-space-between"> <div>HPD investigating hit and run</div> </figcaption> </div> </div> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0qBKcXXz0ktKr"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share sharebar flex-container-column text-align-right"> <button class="social-icon spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Huntsville+Police+identify+man+involved+in+hit-and-run+on+University+Dr.&amp;url=https%3A%2F%2Fwww.waff.com%2F2020%2F12%2F12%2Fhuntsville-police-investigating-hit-and-run-university-dr%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-twitter social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <button class="social-icon spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.waff.com%2F2020%2F12%2F12%2Fhuntsville-police-investigating-hit-and-run-university-dr%2F&amp;title=Huntsville+Police+identify+man+involved+in+hit-and-run+on+University+Dr.', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-facebook-f social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <a href="mailto:?subject=Huntsville%20Police%20identify%20man%20involved%20in%20hit-and-run%20on%20University%20Dr.&amp;body=Read%20more%20on%20Huntsville%20Police%20identify%20man%20involved%20in%20hit-and-run%20on%20University%20Dr.%20at%20https%3A%2F%2Fwww.waff.com%2F2020%2F12%2F12%2Fhuntsville-police-investigating-hit-and-run-university-dr%2F"> <button class="social-icon spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="far fa-envelope social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0z3yJ5Xz0ktKr"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/egraves/"> <span class="font-bold ">Eric Graves</span></a> <span class="font-bold">|</span> <span class="timestamp"> December 12, 2020 at 6:47 AM CST - Updated December 12 at 1:41 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0OiAz6Xz0ktKr"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>HUNTSVILLE, Ala. (WAFF) - <b>Update: </b>Huntsville Police Department identified the man who was involved in a hit-and-run on December 12. </p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>WAFF is told that Daniel Mark Banks was arrested for fleeing the scene of the accident. Banks was allegedly driving under the influence. </p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>HPD is investigating this case.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p><b>Original: </b>One person is at Huntsville Hospital with severe injuries after what Huntsville Police said was a hit-and-run early Saturday morning.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad977-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad977" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad977",slotName:"waff/web/news/top-story/R4Z5KGXAIZHGJHP7VGYOY7ZYQQ",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>One HPD officer on scene said the hit and run happened around 3:30 a.m. at the intersection of University Dr. and Enterprise Way.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>At last update, HPD is still looking for the suspect who hit the victim with their car. Officers blocked off westbound University Dr. between Enterprise Way and Perimeter Parkway NW while they investigated the scene.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>This is a developing story, we will update you when we know more.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2020 WAFF. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-connatix" id="fwaAKx1Xz0ktKr"> <div class="flex-grid ad-connatix spaced spaced-lg spaced-top spaced-bottom "> <div class="col desktop-12 tablet-12 mobile-12"> <div id="connatix-highlights-embed" class="connatix-container box-shadow-light"> <script id="a1c1c57f95064f50bba9396a0b142ced">cnxps.cmd.push(function(){cnxps({playerId:"6ee2b97f-2b1a-439e-b692-7b4ad2f5ea14"}).render("a1c1c57f95064f50bba9396a0b142ced")});</script> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f06efnJXz0ktKr"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="https://www.waff.com/2020/12/12/huntsville-police-investigating-hit-and-run-university-dr/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="https://www.waff.com/2020/12/12/huntsville-police-investigating-hit-and-run-university-dr/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-arcads tablet-6 mobile-12 desktop-12" id="fzMDJM1Xz0ktKr"> <div id="ad1920-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1920" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1920",slotName:"waff/web/news/top-story",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"R4Z5KGXAIZHGJHP7VGYOY7ZYQQ"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-6 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="f47aum1Xz0ktKr"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-cloudy" data-default-location-code="USAL0287" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="waff" data-location-code="USAL0287" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USAL0287,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="https://www.waff.com/weather"> <img class="radar-image" src="https://webpubcontent.raycommedia.com/waff/weather/radar/doppler.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="61" data-temp-c="16"> 61</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/67_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Huntsville, AL</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="https://www.waff.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> <div class="flex-container-row justify-center spaced spaced-md spaced-bottom spaced-top font-semi-bold"> <span class="spaced spaced-right spaced-sm">Sponsored By</span> <div id="ad874-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad874" class="arcad ad-120x30"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad874",slotName:"waff/web/weather-widget",adType:"weather-sponsorship",dimensions:"[[[120, 30]], [[120, 30]], [[120, 30]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"weather",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:false,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-article-author-bio" id="frRRQ42Xz0ktKr"> <div class="article-author-bio"> <div class="article-author-bio flex-grid flex-feature"> <h3 class="bold uppercase"> <span class="rectangle"></span> Author </h3> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="Eric Graves" data-src="https://www.waff.com/resizer/iZEZrDTGv50C1XIQlcqoox8ZAKM=/1400x0/s3.amazonaws.com/arc-authors/raycom/94bde953-2889-44d1-b0e6-f461b1635276.png" src="https://www.waff.com/resizer/DyCbzl8PRISCdWWAuDuQXMYoLgM=/0x10/s3.amazonaws.com/arc-authors/raycom/94bde953-2889-44d1-b0e6-f461b1635276.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/egraves/"> <h3 class="promo-header">Eric Graves</h3> </a> <h4 class="spaced spaced-xs spaced-bottom font-normal color-grey-dark">Anchor/Reporter</h4> <h4 class="spaced spaced-xs font-normal color-grey-dark">Huntsville, Ala.</h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-lg"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://twitter.com/reportereric" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="www.facebook.com/EricGravesWAFF/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">Eric Graves joined the WAFF 48 News team in June of 2019, he is a reporter and weekend morning anchor. He’s excited to call the Tennessee Valley his new home and tell the stories of the people living here.</p> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-mailchimp-signup" id="fxwHfN1Xz0ktKr"> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0NRdx1Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fhr3sb2Xz0ktKr"> <div class="flex-feature "> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-140422" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2020/12/12/rocket-city-marathon-full-swing-through-month-december/"> <img class="width-full " alt="Rocket City Marathon in full swing through the month of December! " src="https://www.waff.com/resizer/gWO-wK89HemkseIVlnVnFbBx9Sk=/1200x600/cloudfront-us-east-1.images.arcpublishing.com/raycom/GVL24SESFRFLLHWNE35T655ZAI.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/12/rocket-city-marathon-full-swing-through-month-december/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Rocket City Marathon in full swing through the month of December! </a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Competitors can run anywhere they want and on their own time, as long as they complete the race by Dec. 31, 2020.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Kellie Miller</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2020/12/12/free-covid-testing-local-church/"> <img class="width-full " alt="Free COVID-19 testing at local church" src="https://www.waff.com/resizer/Cw8W0nOsAY8TMk0v-qu6YByxdzM=/1200x600/cloudfront-us-east-1.images.arcpublishing.com/raycom/SM45MCBOQJCG5ORXTHHLDPDH3Q.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/12/free-covid-testing-local-church/"> Free COVID-19 testing at local church</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">New Life Seventh-day Adventist Church is offering free COVID-19 testing today from 1 p.m. to 4 p.m</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>WAFF 48 Digital Staff</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f09JMK9Xz0ktKr"> <div id="ad517-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad517" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad517",slotName:"waff/web/news/top-story",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"R4Z5KGXAIZHGJHP7VGYOY7ZYQQ"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c008fu9Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fmrOMh1Xz0ktKr"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-122150" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/12/07/sippin-cider-downtown-athens/"> <img class="width-full " alt="Athens Main Street hosts Sippin’ Cider event on Saturday" src="https://www.waff.com/resizer/hoQ3sb_ZL3vVBV3JAWSligvPH2k=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/3GTZ7AJSLJH5DIE2KE2JU65JDQ.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/07/sippin-cider-downtown-athens/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Athens Main Street hosts Sippin’ Cider event on Saturday</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Anna Mahan</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 5h at 8:39 AM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/12/11/warmer-start-today-with-rain-ahead-weekend-2/"> <img class="width-full " alt="Saturday starts with rain, sunshine by your afternoon" src="https://www.waff.com/resizer/ZFW82-vn1_4iZ1ZZrru6cOO5ApU=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/3H2WHAGRPFD2PEPZJWN4S4BRAY.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/11/warmer-start-today-with-rain-ahead-weekend-2/"><i class="far fa-play-circle" title="Has Video"></i>&nbsp; Saturday starts with rain, sunshine by your afternoon</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>Abigail Degler</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 6:59 AM at 6:59 AM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/12/12/pandemic-leading-possible-toy-shortage-around-country/"> <img class="width-full " alt="Pandemic leading to possible toy shortage around the country" src="https://www.waff.com/resizer/FtvVaPGmCKE9BYjVRR968G0M69E=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/KKRAXGMYH5HE3A7D4GK3LAAMSU.bmp"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/12/pandemic-leading-possible-toy-shortage-around-country/"> Pandemic leading to possible toy shortage around the country</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Joshua Gauntt</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 6:39 AM at 6:39 AM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/12/12/amber-alert-charlotte-police-looking-five-missing-children-believed-be-danger/"> <img class="width-full " alt="Amber Alert canceled for Charlotte children" src="https://www.waff.com/resizer/sWIwE2t5Te25UMfsiu56mz-irzM=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/2JQKAUDMHFBZDER5DKVDRGZAGM.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/12/12/amber-alert-charlotte-police-looking-five-missing-children-believed-be-danger/"> Amber Alert canceled for Charlotte children</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span><span>Kristi O'Connor</span></span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 5:10 AM at 5:10 AM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0XShVkXz0ktKr"> <div id="ad1094-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1094" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1094",slotName:"waff/web/news/top-story",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"R4Z5KGXAIZHGJHP7VGYOY7ZYQQ"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},
{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fU2oFF1Xz0ktKr"> <footer class="card card-dark padded padded-bottom padded-0"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.waff.com"> <div class="logo logo-large logo-footer"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 1414 North Memorial Parkway<br/>Huntsville, AL 35801<br/>(256) 533-4848 </p> <a class="call-to-action uppercase color-white" href="https://webpubcontent.gray.tv/gdm/fcc/waff-fcc_applications.pdf">FCC Applications <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div id="ccpa-link" class="call-to-action ccpa-dynamic-insertion-container uppercase color-white"></div> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://webpubcontent.raycommedia.com/waff/PDF/eeo-2020.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.waff.com/story/12117541/closed-captioning-contact-information" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">WAFF Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> <li><a href="http://www.waff.com/about-us" class="color-white">Contact Us</a></li> <li><a href="http://publicfiles.fcc.gov/tv-profile/waff" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@waff.com" class="color-white">publicfile@waff.com<br/>(256) 533-4848</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/waff48" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://facebook.com/waff48" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://instagram.com/waff48" target="_blank" role="button" aria-label="Visit Instagram" rel="noopener noreferrer"> <i class="fab fa-instagram "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://webpubcontent.raycommedia.com/waff/PDF/eeo-2020.pdf" class="color-white">EEO Report</a></li> <li><a href="http://www.waff.com/story/12117541/closed-captioning-contact-information" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">WAFF Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> <li><a href="http://www.waff.com/about-us" class="color-white">Contact Us</a></li> <li><a href="http://publicfiles.fcc.gov/tv-profile/waff" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@waff.com" class="color-white">publicfile@waff.com<br/>(256) 533-4848</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/waff48" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://facebook.com/waff48" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://instagram.com/waff48" target="_blank" role="button" aria-label="Visit Instagram" rel="noopener noreferrer"> <i class="fab fa-instagram "></i> </a> </span> </div> </div> </div> </div> <div class="footer-copyright width-full bordered bordered-top-darken spaced spaced-top spaced-sm"> <div class="container"> <p class="font-sm color-white text-align-center spaced spaced-sm spaced-top spaced-bottom"> <span>A Gray Media Group, Inc. Station - &copy; 2002-2020 Gray Television, Inc.</span> </p> <div class="footer-corp-logo width-full spaced spaced-sm spaced-top spaced-bottom"></div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rHJ9vP1Xz0ktKr/render.js?v=101'></script> <script>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</script> <script>window.banditoEnv={TIMEOUT:1500,PERF_API:"https://bandito-events.perso.aws.arc.pub/api/save-perf",TESTS_API:"https://bandito.perso.aws.arc.pub/api/variants",EVENTS_API:"https://bandito-events.perso.aws.arc.pub/api/save-event"};if(window["pageBuilder"]&&window["pageBuilder"]["initVariants"])window.pageBuilder.initVariants({IS_ADMIN:false,TIMEOUT:window.banditoEnv.TIMEOUT,PERF_API:window.banditoEnv.PERF_API,TESTS_API:window.banditoEnv.TESTS_API,EVENTS_API:window.banditoEnv.EVENTS_API});</script> <script async src="/pb/resources/dist/199071bbaf3b531cbc00/rm/rm-index199071bbaf3b531cbc00.js"></script>